Flashblade / MLAG configuration

I have built so many of these that I decided to document the buggy little network things so I can reproduce the same build over and over.

I have been building on 10/40g Arista switches using their typical MLAG configuration. If your familar with MLAG this is very straight forward. We also use 40G interfaces when possible.

Please see the

#This is the MLAG config on each switch

no spanning-tree vlan 4094

vlan 4094
trunk group mlagpeer
!
interface Port-Channel10
description MLAG PEER
switchport mode trunk
switchport trunk group mlagpeer
!

interface Vlan4094
ip address 10.0.0.1/30 (10.0.0.2/30 for second switch)

#Port channel configuration (both switches should have this build)

interface Port-Channel1000
description Flashblade LINK
switchport mode trunk
mlag 1000
spanning-tree portfast

#Interface config on ports to add to port channel

interface Ethernet19/2

description Flashblade PO do not remove!
channel-group 1000 mode active

#MLAG configuration

mlag configuration
domain-id mlag1
local-interface Vlan4094
peer-address 10.0.0.2
peer-link Port-Channel10
!
Here is the process for changing the ports from 10G interfaces to 40G interfaces on FB.

#Change the ports from 10-40g
purehw group –qsfp CH1.FM1.ETH1.1
purehw group –qsfp CH1.FM1.ETH2.1
purehw group –qsfp CH1.FM1.ETH3.1
purehw group –qsfp CH1.FM1.ETH4.1
purehw group –qsfp CH1.FM2.ETH1.1
purehw group –qsfp CH1.FM2.ETH2.1
purehw group –qsfp CH1.FM2.ETH3.1
purehw group –qsfp CH1.FM2.ETH4.1

#validate the port configs
purehw list –type eth
#revert back to 10g interfaces
purehw ungroup –qsfp CH1.FM1.ETH1

 

Be the first to comment

Leave a Reply